Google требует от производителей аппаратной поддержки уведомлений Android 7.1

14:49, 12 января. Автор: Источник: Android Police

Компания Google на этой неделе обновила требования по совместимости устройств с операционной системой Android (Compatibility Definition Document). Этот документ содержит положения которые являются обязательными для всех производителей, так и те, которые лишь желательны, но все они направлены на то, чтобы созданное устройство соответствовало представлениям Google. В частности смартфоны должны реализовывать возможности операционной системы, включая ее новейшие версии.

Для совместимости с ОС Android 7.1 компания Google будет требовать обязательной поддержки новой системы уведомлений. То есть любой аппарат, производитель которого пожелает установить на него Nougat должен обеспечить возможность управления нотификациями непосредственно из панели нотификаций, возможность визуально определить возможность вызова этой панели, а также возможность блокировать, переводить в беззвучный режим и сбрасывать нотификации как на панели уведомлений, так и непосредственно в приложении.

При этом многие другие нововведения пока остаются лишь опциональными, а не обязательными для Android 7.0 Nougat.