Google решил проблему совместимости эмодзи в Android

18:24, 26 июля. Автор: Источник: Цифровая Москва

Не секрет, что совместимость приложений является ахиллесовой пятой разнообразия версий ОС Android, но есть и менее очевидные проблемы, которые постепенно решаются. Одной из таких, уже бывших проблем является совместимость эмодзи. Разные версии ОС Android по-разному трактуют наборы символов, передаваемых как эмотиконы, поэтому потребовалось создать специальную программу EmojiCompat, чтобы пользователи видели всегда одни и те же смайлы. Библиотека EmojiCompat включает обратно совместимые шифры, что позволяет всем пользователям видеть новые эмодзи вне зависимости от того насколько устарела их версия ОС. Впрочем, совсем старые версии ОС Android не поддерживают EmojiCompat, для работы требуется ОС Android 4.4 KitKat или новее.